Autor Tema: Problema con el driver para motores paso a paso unipolares con 74LS194  (Leído 3858 veces)

xose_maria

  • PIC10F
  • *
  • Mensajes: 5
Hola a todos.

Una vez que me he presentado en el hilo correspondiente paso a comentar el problema que estoy teniendo con el driver para motores paso a paso unipolares con 74LS194 que he visto en vuestra página "googleando".

Estoy haciendo una máquina de reballing y me he propuesto subir y bajar el Hotgun a través de un husillo con un motor paso a paso unipolar recuperado de una impresora HP y el driver antes comentado.

Este motor consume 800mA y claro está el ULN2003 que viene en el circuito no me vale y me propuse montar el ULN2008 que puesto en parejas aguanta hasta 1A para hacer las pruebas si bien tengo pensado sustituirlo por transistores Darlington.

He montado en protoboard dicho circuito y haciendo las pruebas girando en sentido horario y antihorario el motor funciona perfectamente pero en cuanto lo paro se me dispara el consumo hasta 1A con el consiguiente aumento de temperatura con lo cual no puedo ni tan siquiera tocarlo al cabo de unos minutos.

He comprobado que la salida A en el Pin 18-17 del ULN2008 está activa y por ello ese aumento de corriente y temperatura con el motor parado. ¿Le ha pasado a alguien esto? ¿Estoy haciendo algo mal? Con el motor parado ¿no deberían estar las bobinas desactivadas?

Muchas gracias por vuestra atención.

Saludos.
« Última modificación: Septiembre 21, 2012, 09:00:29 pm por xose_maria »

Suky

  • **----- ^^ ------**
  • Moderador
  • dsPIC
  • ******
  • Mensajes: 5442
  • Con Qt...
    • micros-designs
Re: Problema con el driver para motores paso a paso unipolares con 74LS194
« Respuesta #1 en: Septiembre 21, 2012, 11:12:25 pm »
Hola! Es el ULN2803 el que utilizas? Conectaste el pin 10 a Vcc?


Saludos!

xose_maria

  • PIC10F
  • *
  • Mensajes: 5
Re: Problema con el driver para motores paso a paso unipolares con 74LS194
« Respuesta #2 en: Septiembre 22, 2012, 06:09:28 am »
Hola.

Sí, está todo bien conectado. Acabo de releer de nuevo el artículo y me he fijado en el apartado que habla de S1. Probaré a llevar a GND el pin 2 del 555 a ver si con eso cesa toda actividad en el circuíto.

Saludos.

xose_maria

  • PIC10F
  • *
  • Mensajes: 5
Re: Problema con el driver para motores paso a paso unipolares con 74LS194
« Respuesta #3 en: Septiembre 22, 2012, 07:54:36 am »
Hola de nuevo.

Nada, he probado a poner el pin2 del 555 a GND con lo cual deja de emitir pulsos y el motor se para pero aleatoriamente una de las bobinas del motor pap (A,B,C o D) queda consumiendo 1A. No sé si es un problema de diseño o es que tiene que ser así.

Desconozco (a ver si puedo hacer esta tarde la prueba) si quitando el ULN2803 y colocando en su lugar NPN darlington se solucionaría el problema pero me imagino que no que es cosa del SN74194. Realmente no lo sé.

Aprovecho este momento para preguntaros si haciendo un circuito controlado por pic se podría programar para que al darle al stop cesara todo consumo en las bobinas del motor.

Gracias por vuestra atención.

Saludos.

Ariel

  • Global Moderator
  • dsPIC
  • ****
  • Mensajes: 10753
    • uControl
Re: Problema con el driver para motores paso a paso unipolares con 74LS194
« Respuesta #4 en: Septiembre 22, 2012, 09:51:15 am »
Aprovecho este momento para preguntaros si haciendo un circuito controlado por pic se podría programar para que al darle al stop cesara todo consumo en las bobinas del motor.

Si, claro! Con un PIC eso es fácil ;)

Saludos!
Si cualquier habilidad que aprende un niño será obsoleta antes de que la use, entonces, ¿qué es lo que tiene que aprender? La respuesta es obvia:
La única habilidad competitiva a largo plazo es la habilidad para aprender
“. Seymour Papert

вoяяe

  • .::. µPraxis .::.
  • Amigo de uControl
  • PIC18F
  • ******
  • Mensajes: 1346
  • вoяяe
    • вyвoяяe
Re: Problema con el driver para motores paso a paso unipolares con 74LS194
« Respuesta #5 en: Septiembre 22, 2012, 10:49:27 am »
Hola de nuevo.

Nada, he probado a poner el pin2 del 555 a GND con lo cual deja de emitir pulsos y el motor se para pero aleatoriamente una de las bobinas del motor pap (A,B,C o D) queda consumiendo 1A. No sé si es un problema de diseño o es que tiene que ser así.

Desconozco (a ver si puedo hacer esta tarde la prueba) si quitando el ULN2803 y colocando en su lugar NPN darlington se solucionaría el problema pero me imagino que no que es cosa del SN74194. Realmente no lo sé.

Aprovecho este momento para preguntaros si haciendo un circuito controlado por pic se podría programar para que al darle al stop cesara todo consumo en las bobinas del motor.

Gracias por vuestra atención.

Saludos.

Hola xose_maria

Estas siguiendo exactamente el circuito propuesto del articulo ??, tendrás alguna foto de tu montaje!!

Saludos!
La electrónica es simple, puedes aprenderla en 100 simples lecciones, una lección cada año.

Siberian Labs

  • Visitante
Re: Problema con el driver para motores paso a paso unipolares con 74LS194
« Respuesta #6 en: Septiembre 22, 2012, 02:33:46 pm »
Yo te diría que te fijes en la página del autor ya que el circuito es del año 2008 y fué reemplazado por uno nuevo recientemente.

http://home.cogeco.ca/~rpaisley4/Stepper2012Unipolar.html

Independientemente de lo anterior, puedes probar colocando una resistencia de pull-up en los transistores Q6 y Q7 de 3.3K o 4.7K conectada desde el colector a VCC.

Saludos!

.... O probar este ( perdón por el autobombo )
« Última modificación: Septiembre 22, 2012, 02:41:52 pm por Siberian Labs »

xose_maria

  • PIC10F
  • *
  • Mensajes: 5
Re: Problema con el driver para motores paso a paso unipolares con 74LS194
« Respuesta #7 en: Septiembre 22, 2012, 07:11:50 pm »
.... O probar este ( perdón por el autobombo )

Eso es una señora controladora y lo demás tonterías. :alaba

E_Blue

  • PIC24F
  • *****
  • Mensajes: 2226
  • Electric Blue
Re: Problema con el driver para motores paso a paso unipolares con 74LS194
« Respuesta #8 en: Septiembre 23, 2012, 12:54:49 am »
Siberiano me intriga como hiciste para estañar el PCB. :duda

Vos y tus "mañas" de pichicho experto. ;D
U2kgZXN0YXMgbGV5ZW5kbyBlc3RvIGVyZXMgdW4gTkVSRCEhIQ ==
Procesando...

Si quieres ayuda con tu proyecto recuerda agregar información del mismo, y no seas haragán y esperes tener todo servido, esto es un foro, no una bolsa de trabajo.

Siberian Labs

  • Visitante
Re: Problema con el driver para motores paso a paso unipolares con 74LS194
« Respuesta #9 en: Septiembre 23, 2012, 02:14:46 am »
Siberiano me intriga como hiciste para estañar el PCB. :duda

Vos y tus "mañas" de pichicho experto. ;D

Fijate acá que algo le habia dicho al respecto a HJ, cualquier duda repreguntá en ese hilo asi no desvirtuamos este.

y nuevamente disculpen, me había olvidado por completo que lo había publicado aca en el foro  :embarrassed:

Saludos!!!

E_Blue

  • PIC24F
  • *****
  • Mensajes: 2226
  • Electric Blue
Re: Problema con el driver para motores paso a paso unipolares con 74LS194
« Respuesta #10 en: Septiembre 26, 2012, 01:12:58 am »
Gracias. ;)
U2kgZXN0YXMgbGV5ZW5kbyBlc3RvIGVyZXMgdW4gTkVSRCEhIQ ==
Procesando...

Si quieres ayuda con tu proyecto recuerda agregar información del mismo, y no seas haragán y esperes tener todo servido, esto es un foro, no una bolsa de trabajo.